Wand Update failed - how can I try it again?

Hi There!
I’m new to the Harry Potter Kit. I installed it on my mac and it said that I should update my wand. So I did it, but then I received the message ‘Upate failed. please try again later.’. But now I can’t find any control to update my wand. Even if I connect it as a new Wand there is no option for updating.

It is written that Wand is version v1.0.4. Is this the newest version? maybe updating was successful although there was this failure message…

Sounds like the update was successful if you’re still able to use the wan and there aren’t any update prompts. If in doubt, best to email the support team.