Unable to update Kano OS: No Space

Hello, I’m currently on Kano OS 3.8. Rasberry PI 2. When I try to run the updater it says I’m out of space. It asks if I want to create more space, and I select OK. After it restarts it just goes back to the main desktop. If I run the update again and hit cancel, I get a slightly different message: error in the root phase.

If I run terminal and use df -h there is 5.8G of the 7.1G available in /dev/root directory. Looks like I only need a few additional MB to free up.

Where is the best way to free up space on the card?

Hi @willychaz,

Please run the below from Terminal:

  1. sudo apt-get clean && sudo apt-get autoremove
  2. sudo rm -rf /var/tmp/
  3. sudo rm -rf /var/log/kano/
  4. sudo rm -rf ~/.kano-logs/

Then launch the updater and you should be good to go!

Note: the newest version of Kano OS you’ll be able to get for the Rpi2, is v4.0.0. To get the newest builds you would need to upgrade to an Rpi3b

1 Like

Hey Chris, this worked great! Thank you

1 Like