Superthread - How to run Kano OS on a Pi 3B+

For Christmas 2018, I gave my 8-year-old daughter the Harry Potter Kano Kit, and while deciding on what to get I had a hard time deciding between it an a Kano Computer Kit. Then I found out that the Kano OS can be downloaded and installed on your own Raspberry Pi hardware, and also that newer releases of the OS will boot on the new Raspberry Pi 3B+ that was released on Pi Day (3/14/2018).

The Pi 3B+ improves on the 3B with

  • A 200MHz increase in max processor speed, to 1.4GHz, giving a 10-20% performance boost
  • Gigabit Ethernet, which although throttled by the USB 2.0 hardware, is up to 3 times as fast as the Pi 3B’s 100Base Ethernet connection.
  • Dual-band 802.1ac WiFi, allowing a 5GHz WiFi connection, again at speeds around 3 times as fast as a Pi 3B’s 2.4GHz connection.
  • Power-over-Ethernet (PoE) support, which allows the Pi 3B+ to be run on a single ethernet cable when used with appropriate hardware.
  • Improvements to booting via Ethernet (PXE) and USB mass-storage

(For more technical details on the improvements, please see this Rapsberry Pi Blog post.)

Another great thing is that the 3B+ costs the same as the 3B.

So, encouraged by her positive experience with the Harry Potter Kano Coding Kit, I decided to try using a Pi 3B+ to set up a custom Kano OS Pi computer for my daughter to continue learning about coding and computing.

As of January 2019, Kano OS does not officially support running on a Pi 3B+, but I have successfully gotten it to work great with a few relatively simple fixes for a small number of issues. Some of the issues are related to running on a Pi 3B+, and some are related to using a newer beta version of Kano OS. I will maintain a list of issues encountered in this first post of this thread, and as I add posts explaining the required fixes, I’ll put links to them here as well.

Again, as of January 2019, Kano OS beta 4.2 is the version that should be used with a Raspberry Pi 3B+ and the image file and instructions explaining how to (re)install Kano OS can be found on this Kano Help Center web page. For step 2, make sure to click the link to download for “Raspberry Pi 3 with a 8GB memory card (Computer Kit Complete and Computer Kit Sold February 2016 Onward)”.

You should be able to boot Kano OS beta 4.2 unmodified on a Raspberry Pi 3B+; however the first thing to do that may fix any of the issues listed below is to update the Kano system. After a fresh install of the Kano OS, going through the introduction, and finishing the setup of WiFi, logging into a Kano World account and viewing the Dashboard, you should see a System Update notification like this:


When you click “Install”, the screen will go blank, and the update will begin. It should look like this:


When the update is complete, the computer will restart automatically, and hopefully at least some of the earlier issues I’ve encountered will already be fixed.

Here are the issues that I’ve encountered running Kano OS 4.2 on a Raspberry Pi 3B+, along with their solutions:

  • TV Audio Out (via HDMI connection) doesn’t work
    If the system update (as explained above) doesn’t fix this issue, then see this post for the solution.

  • The user-selected WiFi network is “forgotten” on every reboot.
    This is a known issue in Kano OS 4.2, not specific to the Pi 3B+, as explained in this thread which gives an official workaround.

  • 5GHz WiFi networks are not listed in the Network Settings window of Kano OS
    If this happens, you should try changing your 5GHz router settings to use a “dual-band” channel (40MHz) instead of a “quad-band” channel (80MHz). Although I have managed to connect to mind manually, Kano OS on the Pi 3B+ doesn’t seem to recognize quad-band 5GHz networks. Note that changing to a dual-band configuration will reduce the maximum possible network speeds, however.

  • VNC (graphical desktop remote access) didn’t work “out of the box” for me.
    I have chronicled my experience getting VNC working in this thread. But I hope to post much more explicit instructions in this thread soon.

  • Pairing an Apple Wireless Keyboards is very difficult.
    This may just be a problem with Apple Wireless Keyboards, but from what I read they should be fairly easy to pair with a Pi. I think the real issue is with Kano OS’ bluetooth menu. I will try to go through my notes / recollections to put together instructions in this thread soon.

  • My Pi 3B+ takes quite a while to reboot / shutdown.
    I’m not sure if it’s related to Kano OS 4.2, running it on my Pi 3B+, but when I reboot or shutdown the Pi, it spends well over a minute displaying a message about a “stop job” for “User Manager for UID 1001”. If you also experience this, please let me know. I am doing research on this issue, which is really just a minor annoyance.

If you are running Kano OS on a Raspberry Pi 3B+, please share your experiences and any issues / troubles you’ve encountered that are not listed above. Thanks!


Great post, @flyingtacos! I feel like with another user out there trying the same thing, there’s some support out there. Thanks to you, I have decided to keep pushing on with the 3B+ setup.


Hey @flyingtacos.

I re-flashed 4.2 with the directions you provided and now everything is working well. Some notes:

-I did not have to do the sound workaround you mentioned. After flashing the latest update and running the update it prompted me to run at log-in, I was able to switch from Analog to TV, reboot, and it worked flawlessly.

-I have a regular USB keyboard and mouse and it works well with Kano and the 3B+.

-I’m not having any issues with a long boot, so it could be some of the changes you made.

Anyway, I hope that helps. As two 3B+ Kano users who set up machines for their daughters… we’ll figure this out together!


How to get TV Audio (via HDMI) working

If you’ve used an HDMI cable to connect your Raspberry Pi to a TV or monitor with built-in speakers, you should be able to send audio via the HDMI cable by opening Settings by clicking the gear icon while viewing the Kano’s dashboard, selecting Audio, and then selecting TV for the audio output, like this:


Normally you’d then just need to select “Apply Changes” and click the X in the upper-right corner of the wind, and when the “Reboot?” dialogue appears, select “Reboot Now” to reboot the Pi and make the change permanent.

However, with a fresh install of Kano OS 4.2 on a Pi 3B+, the TV (HDMI) sound out won’t work, and the Sound setting reverts to Speaker (analogue).

The first thing to do that may fix this issue is to update the Kano system. Please see the first post of this thread for details on how to update the Kano system. But if TV (HDMI) sound out is still not working after the system update, here’s the way to fix it:

  1. Find the Terminal App, by selecting the last page of app groups, as indicated with the red arrows in this screenshot:

  2. Open the Terminal app. Make sure it’s not Terminal Quest, which is a game that teaches kids how to use the terminal. The Terminal app icon looks like this: 14%20PM

  3. You are going to remove the Pi 3B+'s sound module from a blacklist that prevents it from being loaded. Navigate to the directory with the sound module blacklist file, by typing:
    cd /etc/modprobe.d
    (and then pressing return/enter)
    You will know that it worked because the terminal prompt will change to:
    YourUsername@kano /etc/modprobe.d $

  4. Display the contents of the modprobe.d directory with a list files command, by typing:
    (and then pressing return/enter)
    The files will be listed in three columns, and you should see the sound module blacklist file, with the name snd_bcm2835_blacklist.conf.

  5. Rename the blacklist file which is preventing the sound module from loading, by typing:
    sudo mv snd_bcm2835_blacklist.conf snd_bcm2835_blacklist.bak
    (and then pressing return/enter)

  6. Because renaming a file requires special user priveledges, the sudo (Super User) command is used here, which will require you to type in your user password. You will see this:
    [sudo] password for YourUsername:
    Just type in your user’s password. If you haven’t changed it, the default password is kano. You will not see anything appear as you type the password. Just type it and then press return/enter. If it was incorrect, you’ll see a message, and just try again.

  7. Check that the file was renamed by again displaying the contents of the modprobe.d directory. Type:
    (and then pressing return/enter)
    You should see the three columns of files, now including a file named snd_bcm2835_blacklist.conf. By renaming the file to have the extension .bak , it won’t be recognized when the Pi 3B+ boots and its sound module will be allowed to load. Here’s what your Terminal window should look like at this point:

  8. Type exit and press return/enter to exit the Terminal app

  9. Click the “power” icon, which is in the lower left corner of the Dashboard and looks like this: 34%20PM. Then select “reboot” to reboot the computer.

  10. After the computer has rebooted, open the Kano OS Settings and select Audio.

  11. Select TV audio output and click “Apply Changes”.

  12. Click the “X” in the upper right corner of the Settings window, and then select “Reboot Now” in the “Reboot?” dialog window that appears. After the computer reboots, the intro music should be played when the Dashboard is first displayed. If you don’t hear anything, check the sound volume level both in the Kano Dashboard as well as on your TV/monitor.


You’re the man, @flyingtacos!

Yes, the shutdown seems to take forever. Not sure what’s happening there. It definitely seems like it’s waiting on something.

1 Like

Hi, I’m looking at getting the Touch Kit and adding a Pi 3B+, was just wondering if it will fit OK (all the ports look to be in the same place, but thought I’d check first). Thanks.

I can’t seem to find the download image for the Raspberry Pi 3B+. Does anyone know where i might be able to find a link to the beta ???

I just had my 8-year-old son help me set up Kano OS on a Pi 3 B+ and it was a pretty painless process, with the exception of the HDMI sound issue which was fixed with the blacklist trick mentioned here. The only other things I noticed: the whole thing runs painfully slow (especially Minecraft) to include boot up and shutdown and it runs about 20 degrees hotter than my Retropie build. 58C vs 38C. I have heatsinks installed but I just ordered a case with a fan to see if that brings it down any because I would like to overclock to see if that solves the bogginess. There were no auto updates as others had mentioned and it said I am current when trying to manually update. We used the 4.2.1 beta image.

Just randomly started getting
“stop job” for “User Manager for UID 1001” message and timer at reboot.

Changes made since last post:
-Setting up HPLIP and CUPS so we could print over wifi
-Installed microsoft font package

Update 2:
-Installed a cheap case with fan and idle temps are now 32C and around 40C under load
-Tested WiFi speeds (80up/70down) to see if that was a cause for some of the slowdown. Not breakneck speeds but pretty impressive compared to what I expected.
-I haven’t messed with overclocking because my son’s non-scientific performance test compared to earlier issues was much improved. He made it through hack Minecraft challenges and played around with dance party on and it “didn’t glitch at all” in his words.

I will continue to monitor and update this post as necessary, but I am guessing that it was just throttling performance as a result of the heat. Anyone figure out additional information about the stop job at shutdown? I am still relatively new to Linux and the Pi, but if anyone smarter than me needs logs to analyze, just let me know! Thanks all.

Seems as though the new version: 4.3.2 freezes at the clouds.

I can’t seem to find a link for 4.2.1 - does anyone have one?

Chris from Kano support got me a link to 4.2.1. Back up and running, but you now can’t login to Kano World as it’s 4.3.2 only.

Anyone got Kano 4.3.2 working on a Raspberry Pi 3B+?

Chris from Kano dropped me a link, I’d reach out to Kano support.

Yes, I have got the latest version of Kano OS (4.3.2), working properly on my 3B+. I just followed the steps of the first post on this thread and got it working first try with no problems so far. However, I only downloaded it yesterday so I haven’t had time to look into everything.

I have been trying to log into my Kano account in Kano OS 4.3.2 on my 3B+, but it’s not working. The account won’t link. I can sign into the Kano World website but not into actual Kano OS. Also, when I open Chromium, it keeps saying in another tab that an update is required. I have been constantly trying to update but it gets to 3% and then just stops.

Is anyone else experiencing these issues?