Setup Issue with Trackpad


#1

I recently re-flashed my SD card and during the on-screen setup, it asks me to activate the trackpad, then use it to click on circles. I click on one circle and it disappears, but another one doesn’t come up and I get stuck on that screen. Has anyone experienced this and resolved it?

Thanks


#2

I hate to add a me too but this also affected us. Flashed “Kanux-Beta-v4.2.0-Hopper-stretch-rc-2018-12-13_14-42-noobs.img” onto a Raspberry Pi 3B+, using a Logitech K400+. I’ve tried a few times with my son on our DIY Lego Pi setup. We get through the tutorial, see a single circle to pop, successfully pop it with the trackpad, but the scene never advances.

Could this be a bug in the latest beta? Or is it an artifact of not using the Kano keyboard & display? We’re using the official Raspberry Pi touchscreen in the SmartiPi case (so ribbon cable, not HDMI).


#3

TLDR: The display resolution on the official Raspberry Pi Display is too low for the Kano OS tutorial.

So I gave a 1080p display a shot this weekend. It worked! There is a bubble to pop on the right side of the display that’s not visible at the resolution of the official Raspberry Pi display. After that, the third bubble would also be too far to the right to click. Once I got my son through the tutorial he was excited to program Minecraft!

Unfortunately, when I moved the Pi back to the low resolution display, the programming environment added to Minecraft is fairly difficult to use, and the Kano dashboard interface doesn’t work, however the Classic Mode interface is very usable! Unfortunately, Classic appears to be missing some of the apps. I may end up purchasing a Kano Touch after all, but I still have a few experiments that I want to run. FYI after the tutorial completed and the Kano OS updated, the touch interface on the Raspberry Pi display works perfectly as well.