New setup, and cannot load the editor

I’m trying to set up the Kano Coding Kit for my kids. We bought two: Frozen and Star Wars. When we try to click to start working on any project, a notification dialogue shows up in the bottom right saying, “We couldn’t load the editor. Sorry about that, please try again”. There is a red circle icon displayed containing a white exclamation mark, and there is an orange OK button, and there is no further explanation. This same

I have a MacBook Pro (Late 2011) running macOS 10.13.2. I had to buy a Bluetooth 4.0 USB adapter to get it to communicate with the Kano, which worked. The app’s about page says:

  • Disney Frozen 2 Coding Kit by Kano 1.3.5
  • electron 3.1.0
  • chrome 66.0.3359.181
  • node 10.2.0
  • v8 6.6.346.32

I’ve searched on the web and haven’t been able to find anything to solve this “couldn’t load the editor” issue. I found one post here that was seeking to run on a Raspberry Pi, but that isn’t supported.

I’ve already went through my Windows 8 laptop, my Chromebook, my iPhones, and my Kindle Fire 7, to find out that none of those were supported. Is there anyone who knows what might be wrong on this old MacBook? Is there an error log somewhere that might give a clue? Is there a permissions issue, since I’m not running in an admin account? Is macOS 10.13.2 not supported?

Back again. I just tried under an admin account (I had to create a new “account” in the app), but it did not make a difference. I have a bad feeling that this MacBook Pro is not compatible with the app.

Me again. I sure would like some help on answering this question. Do I have a compatibility problem, or do I have a problem with how the install was performed? Although I meet all the minimum hardware requirements that are publicly stated, I have a sinking feeling that there is an undocumented hardware incompatibility. I’m really hoping there is a software install or access problem that can be resolved.

Here are the tech specs for Kano Kit Frozen:

Here’s my exact MacBook Pro model: https://everymac.com/systems/apple/macbook_pro/specs/macbook-pro-core-i7-2.4-17-late-2011-unibody-thunderbolt-specs.html

My computer meets or exceeds all the minimum Mac requirements:

  • MacOS 10.13+
  • Intel 64-bit processor Core i7
  • 8 GB RAM
  • Bluetooth LE (via USB adapter)

I don’t think it’s the Macbook that’s the problem. I’m having the same issue on a Dell XPS with Windows 10. The strange thing is it worked fine before. I bought my daughter the Frozen II kit for Christmas, and she finished the whole thing on this same computer. She tried it again maybe a month ago, and we got that same “We couldn’t load the editor.” message. Today we tried it again, tried a clean install, and it still isn’t working. Same version, 1.3.5, downloaded from the Windows Store. Maybe an update broke it?

I’m glad I’m not the only one dealing with this, and that there is a possibility that my computer is compatible. What’s the best way to try to get an answer on this? Is this forum frequented by Kano support folks? I’ll also try reaching out directly to them.

I submitted a request for help to Kano customer service using this link:
https://help.kano.me/hc/en-us/requests/new

After 10 days, I have not yet heard anything back. Does anyone know a more reliable way to get support?

Also, is there a store of previous versions of their Kano Coding Kit apps that I can download from an online archive? Perhaps the 1.3.5 version is prone to this editor failure, as s_georg suggested. Anyone know where older versions can be downloaded?