Kano will not work

My son received a Kano computer kit from Santa yesterday.

We hooked up to a monitor and got the initial screen then it went grey snow. We have tried 2 other tv’s and nothing works. The lights on the raspberry pi 3 will not light up, they have never lit up.

Tried charging the keyboard overnight and will not keep a charge.

What are we doing wrong??

Hi!!!
I’m also new with Kano, but I think there is something that is not plugged in correctly. If you have no lights, I think you need to review all the cables connections.
Good luck!!

Hello
Normally no lights on the board means no power. And it sounds like your also not able to charge the keyboard. Try plugging a cell phone into the charger and seeing if will charge that. If it does not, then you have a bad charger. Also try a different USB cable. If it is charging your cell phone then it points to the mother board. Are you holding the button down for 3+ seconds? I know on the Touch models if you do not hold the button down for at least 3 seconds, it will not start up.
Jeff