Kano Displaying Wrong Time Zone


#1

Hi all, I have three RPIs using Kano in my home. The one I set up a year ago displays the correct time, but the two new set-ups appear to be showing GMT. I feel like an idiot, but I can’t figure out how to set the time zone or adjust the time. What am I missing? Thanks!


#2

Same issue here. My clock time is six hours ahead on a new Kano. Have read the time is supposed to sync with the network connection at boot but my wifi settings do not stick (another issue) and I have to re-enter the wifi password every time I restart.
Tried to run raspi-config from the command line but that won’t load either.
Thanks for any assistance.


#3

This step worked for me: https://www.cyberciti.biz/faq/howto-set-date-time-from-linux-command-prompt/
How do I set the time zone using timedatectl command?

To see list all available time zones, enter:
timedatectl list-timezones timedatectl list-timezones | more
timedatectl list-timezones | grep -i asia timedatectl list-timezones | grep America/New

To set the time zone to ‘Asia/Kolkata’, enter:

timedatectl set-timezone ‘Asia/Kolkata’

Verify it:

timedatectl

  Local time: Mon 2015-11-23 08:17:04 IST

Universal time: Mon 2015-11-23 02:47:04 UTC
RTC time: Mon 2015-11-23 13:16:09
Time zone: Asia/Kolkata (IST, +0530)
NTP enabled: no
NTP synchronized: no
RTC in local TZ: no
DST active: n/a

In regards to the wifi not remembering the pw, see Cris Mann post: After update, Kano Computer won't remember Wi-Fi
Good Luck


#4

That did the trick - thank you!


#5

Another option is just to run “sudo apt-get install raspi-config” and then use “sudo raspi-config” to change the timezone.


#6

Thanks, everyone! Unfortunately, these suggestions are above my current knowledge level. I wrongly assumed it would be easier than that! Where would I type what you’re suggesting I type? Thanks!


#7

Hi,
Please go to the terminal not terminal quest, if you change to dashboard mode it’s on the last dashboard, next to Setting.

Input sudo timedatectl set-timezone ‘Asia/Hong_Kong’
password is kano

done.

So the first thing you need to do is to find your timezone and replace Asia/Hong_Kong with it.