HDMI Sound Reboot Issue: 4.1 v 4.2, RPI 3B v 3B+


#1

I have two RPIs set up with Kano—a 3B which has automatically upgraded to v.4.2 and a new 3B+ which the Kano Updater says is up to date at v4.1. Both RPIs use an HDMI cable to connect to an ASUS monitor with built-in speakers. The 3B with 4.2 works flawlessly with the set-up and always has. However, I can’t get the sound to work on the new 3B+ with v4.1—I go into setting and select TV (for HDMI) instead of Analog, the system prompts me to reboot, and then when the system comes back on the sounds is back on Analog. Is the issue the 3B+ or v4.1 or both? Does v4.2 contain the fix and is it coming for the 3B+ or should I just downgrade from the 3B+ to the 3B? If I did that, would it allow me to upgrade to 4.2 and is that the trick? Thanks for your help!


#2

Hey @theoutdoorsyguy,

We don’t officially support the RPi3B+ (the 3B is used in our newest kits), so you’re a little bit out on your own here… although our engineering team tell me that the audio setup/architecture of the 3B+ is different to that of the 3B so this could be where you’re hitting problems.

Kano OS 4.2 was developed with the 3B in mind, so using the 3B is likely your best route forward! :slight_smile:

Thanks!

Chris


#3

Thanks, Chris!!!

Any idea when/if Kano will support the 3B+? I didn’t want to make the initial post more confusing, but I actually set up two new 3B+ RPIs for Christmas for our twin girls, so I’d have to buy two new 3Bs to replace them. As such, if support for the 3B+ is on the horizon in say v4.3 or something, I’d consider dealing with the audio issue for now. If you can, let me know if there are plans for support.

Either way, thank you for the quick response!!!


#4

No problem!

I’m not sure, but will check in with our engineering team on Monday and come back to you. :slight_smile:


#5

So I went out and got two new RPI3Bs to replace the 3B+s, and I still can’t get the sound to work over HDMI. At this point, everything is exactly the same as the original set-up I have had for a year that has worked well—same monitor, RPI3B, everything… except my son’s 3B has upgraded itself to Kano 4.2 and this new one I got won’t upgrade past 4.1. I found something where a person was saying they had a similar issue with 4.1. Could that be the issue? If so, how can I push an update to 4.2 when the updater is saying I’m up to date with 4.1?


#6

I am running Kano OS 4.2 on a Pi 3B+ and have gotten HDMI sound working by un-blacklisting the sound module used by 3B+, so it’s possible this fix will work with 4.1 as well.

See this post for the solution:

After doing this on my setup, HD sound has been working just great in the Kano OS with every app I’ve tried. If you attempt this incredibly easy fix, please let me know how it goes.


Superthread - How to run Kano OS on a Pi 3B+
#7

Hi @theoutdoorsyguy,

The fastest option would be to download the newest version (4.2) to a windows or mac computer, and then flash it to your SD card using etcher.

You can grab the download from here: https://hello.kano.me/downloads/

And a handy how-to here: https://help.kano.me/hc/en-us/articles/360001063620-Re-install-Kano-OS-Software-Latest-

Thanks

Chris


#8

Thanks, @flyingtacos!

Are you having any other issues using the 3B+ with Kano? It seems to be working fairly well for us, possibly even a bit less laggy than the Kano we have set up on a 3B. I set my twin girls up with Kano on 3B+ but I bought two 3Bs last week when I realized the 3B+ wasn’t technically supported. Whichever versions I don’t end up using will get sold on eBay, so I’m just trying to figure out if the 3B+ is more trouble than its worth or if you’ve found Kano to work well on it and to be worth the internal upgrades. Thanks!


#9

Thanks, Chris! I will give that a shot! Out of curiosity, why has one of my 3Bs upgraded automatically to 4.2 via the Updater and one is saying it is up to date at 4.1? Is it a rolled release for testing or something? Thanks again.


#10

Really not sure on that @theoutdoorsyguy - certainly not expected behaviour.

Could be it’s not getting a stable WiFi connection?


#11

Here are the issues I’ve encountered so far:

  • HDMI Audio Out wasn’t working, as discussed in this thread.
    The solution of removing the sound module from the blacklist as explained in my previous post got everything working perfectly. I had the Pi connected through my living room TV / AV Receiver and the sound quality was perfect, having watched YouTube videos and listened to streaming music on a few websites.

  • My selected wifi network was “forgotten” on every reboot.
    This is actually a known issue in Kano OS 4.2, not specific to the Pi 3B+, but since 4.2 is currently the best choice for running Kano OS on a 3B+, it’s important to mention it here. Please see this thread for an explanation of the workaround, but I’d actually recommend waiting because using a different method I have figured out how to get my Pi 3B+ to connect to my 5GHz network of my dual-band router, which is fantastic. And it’s fast! I plan to start a thread dedicated to the fixes necessary to get a Pi 3B+ working with Kano OS 4.2 soon, and will include instructions for this.

  • VNC (graphical desktop remote access) didn’t work “out of the box” for me.
    This may actually also be due to changes in Kano OS 4.1 or 4.2, but I had to go through a bunch of steps to get it working, and only if I switched from the Dashboard mode of Kano to the “Classic Mode”. I have chronicled my experience getting VNC working in this thread. But I will also add more explicit instructions in the thread I start on working with a Pi 3B+ because I figure other users will encounter it as well.

  • Pairing one of my Apple Wireless Keyboards to my Pi 3B+ was really difficult to accomplish.
    Again, this may just be a problem with Apple Wireless Keyboards, but from what I read they should be much easier to pair with a Pi. I think the real issue is that in the Kano OS’ bluetooth menu, I never saw a dialog asking for me to type the 6 digit passcode which is needed to pair with this keyboard (and also with some other bluetooth keyboards.) So ultimately I had to go through the entire pairing process in terminal. I have no idea if this is an issue specific to the Pi 3B+ or recent the version(s) of Kano OS, but it seems like something that really needs to be addressed either way. I did not start a thread here on the forums since I figured it out on my own in the end, but I will try to go through my notes / recollections to put together instructions in a thread.

  • My Pi 3B+ takes quite a while to reboot or shutdown.
    I’m not sure if it’s related to Kano OS 4.2, running it on my Pi 3B+, or due to one of the fixes I’ve made, but when I reboot or shutdown the Pi, it spends well over a minute displaying a message about a “stop job” for “User Manager for UID 1001”. There’s even a countdown timer displayed along with a prediction of how long it will take to complete:
    IMG_4783
    I don’t recall seeing this message appear the first few times I restarted the Pi, but I wasn’t paying very close attention, unfortunately.

Besides these issues, which I’ve largely resolved, the Pi 3B+ has been running Kano OS and the installed apps just fine. I haven’t used it on a Pi 3B so I don’t have any frame of reference, but it’s quite acceptably fast and responsive enough for most tasks outside watching HD YouTube videos.

As for the question of automatic updates from Kano OS 4.1 to 4.2, I started with downloading and burning an image of 4.2 to my SD card, because I had read in several places that 4.2 was best to use with the Pi 3B+. SO I don’t have any experience there.

If you land up going that way, I’d be interested in one (or two, even), so please send me a PM. I have a home automation setup in my home and a Pi can come in very handy as a 3rd party server to handle the automation of certain products and devices.

EDIT: I have started a new thread dedicated to how to get Kano OS 4.2 running on a Pi 3B+, which can be found here.


#12

Thank you, @flyingtacos! I really appreciate the help. I will keep you in the loop.


#13

Thanks, chris! Just checked the two new machines (one 3B, one 3Bplus) and they’re getting 40mbps down and 10up. The machines sit right next to one of our mesh system’s wifi pods, so it’s a good connection. I ran the updater again on both, and each said they were up to date at 4.1. I will try downloading and flashing 4.2 as suggested, but it is weird that our other 3B we set up last year sitting one room over has automatically updated to 4.2.


#14

EXCITING UPDATE!

I downloaded the latest OS for “Raspberry Pi 3 with a 8GB memory card (Computer Kit Complete and Computer Kit Sold February 2016 Onward,” flashed it to the SD card for the 3B+… and then ran the updates I was prompted to run when I turned the machine on. And guess what? I changed the audio from analog to HDMI and rebooted the machine… and it worked. No changing file names, nothing fancy… it just works now.

I’m still not sure what the issue was with the sound or with the OS not updating by itself. Maybe my buddy that originally flashed the OS for me used an old version or used the one for the Touch Kit or something. Either way, to anyone else out there reading this… flashing the OS is stupid easy (just follow the directions) and afterwards, I now have a 3B+ running the latest version of Kano (4.2) and HDMI sound and everything else seems to work really well.


#15

That’s great news!

However, I have tried flashing Kano OS 4.2 on another SD card to start over fresh, and even after running through the automatic system update, TV sound via HDMI still wouldn’t work.

So I have gone through the process of renaming the blacklist file again to make sure my instructions are 100% correct, and I posted them on my “How to run Kano OS on a Pi 3B+” thread here. Since my previous instructions that I gave in this thread were incorrect, I’ve removed them and instead included a link to my new post that explains it.

Thank you for the feedback!