Failed to sync (kano world)

I try to download app for my old 2016 Kano, but I get an error:
Houston we have a problem, failed to sync

I’ve tried to login to an account that works on, also I’ve tried signing up. Same error message.

Thanks for your help

Hello, are you connected to internet?

Could you try pressing ctrl+alt+f2 on your keyboard, and then logging in (or just open a terminal), and the type ping

Please post the output

Thanks for your reply.

Yes, I could access google.

Will ask to perform the ping command


Don’t bother with ping then, if google works then ping will work

edit: can you actually try ping

Could you try the command sudo apt update and try downloading apps again

OK that works (

Thanks for your messages.
The sudo worked for a moment, after a while I’ve got this message:
dpkg was interrupted, you must manually run ‘sudo dpkg --configure - a’ to fix the problem
We’ve tried again to access the kano world and we still faced the same issue

Could you try the sudo dpkg --configure -a command and tell me what happens

If it doesn’t fix the issue try running sudo apt-get install -f (to fix broken packages) and then try running sudo dpkg --configure -a again.

Could you also try and check your internet parental control settings to see if they are an issue? Thanks


The result of sudo dpkg --configure - a is:
No package named ‘a’ is installed, cannot configure

Then we ran the apt-get, it took a while and seemed to work.
After we re ran sudo dpkg --configure - a but same message as above.

We re ran sudo apt update, then it worked and told me 8 packages we ready to install or update.

After we tried again to install apps from Kano but we had the same sync error.

I don’t remember to have put parental control, but I could check the settings if you tell me where.

Thanks again for your help

Oops sorry, I meant sudo dpkg --configure -a (no space before the a) I’ve now corrected this in original post too

Could you try it again.

Also I have no idea where the parental control settings are - maybe in some settings app (I have not actually used kano os yet)


Yes it works now.
BTW sudo apt update worked and it included that last command :slight_smile:

So now not sure how to proceed with the Kano World conection issue…

Thanks again for your help

One person fixed there kano world sync issue by pressing the update icon on the desktop, updating and then and rebooting (doing that about 3 times) and then it seemed to sync:

Ok so the issue seems to be you need to cancel out of the registration and just let it boot. I did that and after a while an icon shows up on the “desktop” to apply updates. It applied 2 different updates to the system this way. Be forewarned it took over 4 hrs so that really killed the interest in this for my daughter who was dying to use it so plan accordingly. Once those updates are applied you boot into the “desktop” type environment again where there is an icon to register/create an account. If you tried and failed the first time before the updates you will see the create account process now is wildly different from what you saw before the updates which is probably why it didnt work. After the updates are applied I recommend you reboot one last time after it came up from applying the updates the registration process hung again. I rebooted the Kano and it worked fine after that so after you get the last updated applied and it rebooted, once you get into the desktop reboot again maybe you will have better luck than I and it will work firat tey. After that it was all working. Hope this helps.

Another person said

So, after letting the computer sit for a while, it initiated two updates, which took a couple hours. After the updates, I was able to log into the Kano world account.

Also, I had to turn off parental controls on the settings to get the browser to work. The default password is “kano.” I think everything is working for me now. Try running the updater app.

This artical explains how to do an update:

If there is no updater app, you can just go to a terminal and try:
sudo apt update and then sudo apt upgrade

Enter in your password answer any prompts to update

Hello ,

Thanks for the update :slight_smile:

I have no Update icon nor Updater app on the desktop.

I’ll let Kano run a while long, to give it time to identify if anything has to be udpated (in the hope to see the update button appear)!

Keep you posted

Hello again,
First update done, the look and feel is now the latest, the Updater is there.

Still can’t connect Kano World, but should work soon…

Thanks again for your support

Did it work Samos? Because it sounds exactly like the issue I’ve had since October. Doesn’t seem like Kano are in any hurry to fix it, sadly.


The steps describes in this thread have worked. I was able at some point to have the updater visible in Kano and also to run it, nevertheless I couldn’t update since I had not enough space on my 8GB card.

I’ve tried an full upgrade via the commands, but that killed my Kano installation.



What you could do is take the image, back it up and restore onto
a larger card, then run expand image.

would work.


Yes it’s true.

But not having any PC available I’ve decided to download Noobs on a smartphone in which I’ve inserted my SD card, then from Noobs I could install Raspbian (a linux distribution for the raspberry) from the net.