Can You Use The OS On Any PC?

Can You Use The OS On Any PC? I Have A Intel Pentium PC And I Was Wondering If The OS Would Work On It , Because It Doesn’t Have A OS And My Son Likes To Play Minecraft And It Would Be Cool If He Could Code

1 Like

Hi!

Kano OS is engineered as a Raspberry Pi operating system, so it won’t work out of the box on a regular PC. However, you can use virtualization services like VirtualBox to make it work.

Here’s a tutorial on how to do it with regular Raspbian. You just need to use the Kano OS ISO file available here instead of the Raspbian ISO throughout the process.

Hope this helps!

3 Likes

Thanks for making this image available online. :slight_smile:

4 Likes

@David
I followed the instructions you provided above, and tried the install in both VirtualBox and VMware. I couldn’t get either to work. The file like you provided above is a .img file. As far as I can tell VirtualBox and VMWare need a .iso file to boot the OS. Am I missing something? What am I doing wrong?

Thanks in advance!

2 Likes

@Andrew, the easy fix is to rename the file from .img to .iso and that should do the trick. Let me know if that works for you!

2 Likes

Thx 4 the info! I was just looking in my emails and found this fourm that i created. I will try it out!

2 Likes

image
I’m another person trying to do it.
I followed the instructions (including changing .img to .iso) but VirtualBox didn’t like it. D:

Do you know what to do now? :frowning_face:

2 Likes

Mmm, try giving this process a go:

  1. Select a virtual machine by clicking its name in the VirtualBox window
  2. Click the Machine menu at the top of the VirtualBox window, and click Settings
  3. Click the Storage category in the Settings window
  4. Right-click in the storage tree pane, and click Add Floppy Controller
  5. Right-click the Floppy Controller device, and click Add Floppy Device
  6. Click the Choose Disk button in the prompt window that appears
  7. Navigate to the floppy disk image file (.IMG) on your computer and double-click it

If that too doesn’t work, use VBoxManage’s convertfromraw command as follows:

VBoxManage convertfromraw --format VDI [filename].img [filename].vdi

Mount the VDI as a hard disk.

3 Likes

Floppy Method:

Where am I supposed to run VBoxManage convertfromraw --format VDI [filename].img [filename].vdi?

2 Likes

Hi @VukAnd12, just discussed with the engineers around here and they reckon you should give QEMU a try, as it its likely to work. VirtualBox seems to have issues emulating the ARM hardware inside the Pi, which might be the reason why it doesnt work at all.

Give this guide a go but use your image file rather than the raspbian wheezy version they point you to.

Hope this works!

3 Likes

Anybody manage to get this working?

Thx 4 the info! I was just looking in my emails and found this forum that i created. But i forgot to try and i haven’t tried yet.

Can I get to emulate VM VirtualBox?

So there’s good news and bad news.

The good news is that this is entirely possible with the standard Kano images.

The bad news is that it’s a relatively complex procedure, it’s a little bit fragile (if you do one thing wrong it breaks and you won’t know why), and the performance is awful. The Raspberry Pi is not exactly known to be the snappiest computer, but it QEMU emulation makes it look like a springbok.

If anyone is still interested, I can work out what I did to make it work (I did this project back in February and didn’t make any notes, so I’d need to do some experimentation) and make a post with instructions.

Just keep in mind that I’m really not joking about this whole “slow” thing–you’ll struggle to do even simple things in apps, and playing Minecraft is definitely not going to work. It might be helpful if you wanted to try before you buy, or if you wanted to test some idea out, but if you want to actually use the software, you’d probably be better off buying an RPi3B+ for $35.

Anyone still interested?

Yes! Any help would be super appreciated.

Did anyone make it work w/ VM VirtualBox? QEMU won’t work. :thinking::face_with_raised_eyebrow::pensive::neutral_face::frowning:

Did anyone make it work w/ VM VirtualBox?

Unfortunately it’s not possible. See this link, for example.

KanoOS is a modified version of Raspbian, and shares most of its properties, so it won’t run on VirtualBox in the foreseeable future.

I have some preliminary successes in getting this thing to run on QEMU…unfortunately, it’s definitely a Linux-only procedure at the moment because of all the complex shenanigans you have to go through in order to get the image to work. I still haven’t gotten the GUI consistently working yet–will report back when (read: if) I can get that working.

Looking around did bring me to this little piece of software for Windows users. The author claims that it’s a plug-and-play RPi3 emulator, but I have no idea if it’ll run KanoOS, since I don’t have a Windows computer. If anyone wants to be a guinea pig and try it out, it might be a hidden gem. (Fair warning, it also might be a fake product, so I’d suggest at least an antivirus and a little tech knowledge if you want to try it).

1 Like

Nothing is quite so vexing as to have charted out a path, written half an article, and only then discover that someone else has already done it better than you.

The HELLONICO blog has a great article from a year ago on exactly how to emulate raspbian in QEMU. Unfortunately, it seems that KanoOS has some additional hoops that need to be jumped through before a usable GUI can be obtained, and my 2015 laptop just isn’t up to the task of trying to emulate the GUI.

Here’s what I’ve worked out so far:

  • If you follow the HELLONICO instructions, you can get to a terminal screen that invites you to log in. No GUI yet, but we’re at least somewhere.
  • You can log in to the console with username ‘root’, password ‘root’
  • Running kano-init create-user <username> is supposed to create a Kano user with a username.
  • At this point, you should be able to do systemctl start lightdm.service and get a GUI

…and yet, I don’t seem to get one.

I get a mouse, but no kano greeter (which I think is supposed to be what you see once you start lightdm). I’m not sure why, and I’m out of time for the forseeable future to play with this anymore (these lecture slides aren’t gonna write themselves), but hopefully this will help someone find their way towards a working solution.

Thanks. I managed to run Kano for the pi1. It asked me to go into the rabbit hole, but then it seemed to hang after that. I’m not sure what could be the problem, but I was happy to see the Kano logo :slight_smile:

1 Like