After update, Kano Computer won't remember Wi-Fi


#1

After update, Kano Computer won’t remember Wi-Fi. I have to choose the network SSID and enter the passphrase after every reboot or powerup.


Superthread - How to run Kano OS on a Pi 3B+
HDMI Sound Reboot Issue: 4.1 v 4.2, RPI 3B v 3B+
#2

Hi @siobhter,

Talking to the engineering team, there is a known issue in the current version of Kano OS, that they are working to fix in an upcoming update.

Right now, it’s possible to use a workaround that will keep the WiFi connected!

  • Turn on your Kano Computer and wait for dashboard to fade in - the WiFi indicator shows that you’re offline

  • Open up the terminal app (you will find this in the 5th tile along the bottom of the screen)

  • Once terminal has opened, type: sudo mv /lib/dhcpcd/dhcpcd-hooks/10-wpa_supplicant /root

  • Press enter

  • Type password: kano

  • Reboot your Computer Kit

I’ve just tried this on my Computer Kit Touch, and it resolved the connection issue, so should resolve yours too! :slight_smile:

Thanks!

Chris


Internet password help?
#3

Thanks, Chris. I’ll try that tonight.


#4

I was having the same problem with Kano OS 4.2, and I should have started a thread asking about it, because the solution I found online introduces a real security risk:

I found a solution in this Raspberry Pi documentation page on GitHub and elsewhere that explains how to add your wifi network’s name (also referred to as SSID) and password (also known as PSK) to wpa-supplicant configuration file located at /etc/wpa_supplicant/wpa_supplicant.conf. After adding that information, the Kano OS “remembers” the wifi network on every reboot.

The problem with this solution is that leaving one’s private wifi network password in plain text in an easily accessed file is a very high security risk. So the password really should be “masked”, meaning converted to an encrypted string of hexidecimal characters. The above linked Pi documentation page also explains how to accomplish this, but I expect it’s more than most casual users want to be doing in terminal (which would be ironic, given that Kano OS is trying to teach kids how to use and be comfortable working in terminal!)

Interestingly, since I am using a Raspberry Pi 3B+, which now has the capability to connect to 2.4GHz and 5GHz 802.11b/g/n/ac wifi networks, the solution I found should in theory allow me to tell Kano OS to connect to my 5GHz network of my dual-band wifi router, by manually specifying it’s SSID in the wpa_supplicant.conf configuration file.

Currently I’m not able to see my 5GHz in the Kano OS’ graphic interface-based settings, but hopefully in future if the OS is updated to fully support the Pi 3B+ then these rabbit hole dives into command line fixes in terminal will no longer be needed, and all supported wifi networks will just show up in the network settings window.


#5

I ran the move command and my wifi connection now persists after a reboot or shutdown. Thanks for the tip!


#6

Yesterday there was a notification of availability of a Kano system update, and after running the update, it appears that the “forgotten” WiFi network issue may have been fixed.

Also, I now see my WiFi router’s 5GHz network in the list of Kano’s Network setting window, and can successfully connect to it. However, after rebooting, the connection automatically reverts to my WiFi router’s 2.4GHz network (probably because it has somewhat better signal strength).

Since I can’t find any release notes for these system updates, I am burning a fresh copy of Kano OS 4.2 on another SD card to check if this latest update does indeed address the issues.


#7

@searbet have you tried this?


#8

Will try it - thanks!


#9

So, unfortunately, the latest update on top of a freshly installed copy of Kano OS 4.2 doesn’t fix the issue with the user’s selected WiFi network being forgotten on reboot.

As for 5GHz networks showing up in the list in Kano’s Network setting window on my custom Kano setup running on a Pi 3B+, I realized that a change in my 5GHz set up allowed it to appear.

What I changed was the speed / bandwidth setting for the network. It was previously set up as a quad-channel (80Mhz) network, and I changed it to a dual-channel (40Mhz) network. This reduces the theoretical maximum speed, but it more compatible and less prone to interference.